RStudioを使ったCSV形式データの解析

Time-stamp: "2018-06-25 Mon 17:48 JST hig"

ディレクトリ名 exampleは適当に置きかえてください.

計算科学☆実習B(2018)でのRとRStudio(配布資料)

  • スタートボタン>すべてのプログラム>数学・統計・分析>rstudioを実行します.
  • RStudio のプロジェクトを作ります. File>New Project>Existing Directoryで, フォルダQ:\cs2\exampleCreate Projectします.
    大注意:フォルダQ:\cs2\exampleをダイアログから選ぶときに, ウィンドウのタイトルに「ネットワーク…」とか出ていたり, ディクレクトリ名に//や$がはいっていてはいけません. 左コラムの PC>Q:>cs2>exampleとたどってください. そうしないと, Compile Reportで, アクセスが拒否されました, などと言われることがあります.
    プロジェクトは, 仕事のひとかたまり, それに相当するファイルや設定の集まりを表す言葉です. Visual Studio, RStudio はそれぞれプロジェクト単位でファイルを管理しますが, 両者を一致させるかどうかはユーザの自由です.
  • Windows にあわせた文字コードを選びます. Tools>Project Options>Code Editing>Text encodingでCP932を選びます.
    そうしないと, Compile Reportで, 括弧があわないかのようなエラーがレポートされることがあります.
    • Tools>Global Options>Code>Saving>Default text encodingで初期値が設定できるようです.
    • この作業をMacやLinuxでやる人はUTF8のほうがいいかも.
    • Encoding が間違った状態で R Script ファイルを作ってしまった場合, その R Script ファイルは捨てる必要があります. プロジェクトの設定で正しい Text encoding を選び直した後, R Script の内容をメモ帳などにコピー&ペーストしておいて, 新しい R Script ファイルを作って, その中にコピー&ペーストしましょう.
  • ファイル example.R にRのプログラムを書きます. RStudioでFile>New File>R Scriptを選ぶと, ファイルUntitled1を編集するペインが開きます. まだ空白ですが, File>Save Asで, exampleとして保存して名前をつけておきます. R Script ファイルの拡張子 .R が自動的につきます.
  • この中に自分で「Rの」プログラムを書きます. または, サンプル のRスクリプトファイルに貼り付けます.
  • 実行します. RunまたはControl+Enterキーで, 選択範囲または現在の行が実行され, 左下のConsoleや右下のPlotsに結果が現れます. SourceまたはControl+Shift+Enterでファイル全体が実行されます. 変数に代入して保存された値は右上のEnvironmentに表示されます.
  • File>Compile Reportsで MS Word を選んでWord形式のファイルを生成します.
    または, 花火の隣あたりにあるのNotebook iconを押します.
    初回のみ, 追加パッケージのインストールが求められます. OKします.
    このとき, 生成済みの文書をWordで開いているとエラーになるので閉じておきましょう.
  • もちろん, ここでWord文書を編集することができますが, Rで再分析すると失われるので, 編集は R Script ファイルに対して行いましょう.
  • Rを終了するには, File>Close Sessionを選びます. Save workspace image to ... ? ときかれますが, Save を選びます.
    次回に続きをするために状態を保存する処理です.
  • 次回に続きをするときは, RStudioでFile>Open Projectで example.Rprojを選びます.

このサイトのコンテンツ

QRcode to hig3.net

http://hig3.net