Visual Studio 2013でのCプログラミング -- IDEの使い方(含動画)

Time-stamp: "2016-04-20 Wed 17:33 JST hig"

計算機実習室にインストールされたVisual Studio 2013 に含まれる Visual C++ 2013 をIDEでシンプルに使うときの基本的な使い方を説明します. コンソールアプリケーション(コマンドプロンプト内で実行するアプリ)を作成する方法です.

動画による説明(音声あり)

ユーザのホームディレクトリを Q:¥と想定しています. 自宅などの標準的な環境で使う場合は, Q:¥C:¥cs2 などというフォルダを作って代わりに使うことをお奨めします.

Visual Studioの起動

スタート>プログラム>プログラミングソフト>Microsoft Visual Studio 2013>Visual Studio 2013を起動します. 初回起動時に行う設定

新規作成

例として

  • ソリューション名: cs2(科目の全課題共通)
  • プロジェクト名: p021-submit1
  • ファイル名: submit1.c
で説明しましょう. 実際には, 課題で指定された名前を使うか, 自分の責任で決めるかしてください.

図では, ソリューションcs2に, p021-submit1という1つのプロジェクトだけが含まれる.

プロジェクトは, 実行ファイルを作るための複数のファイルの入れ物, ソリューションはプロジェクトを何個かまとめる入れ物, です. 計算科学☆演習では, 1個のファイル なんとか.cだけを1個のプロジェクトにいれ, すべてのプロジェクトを科目を全部まとめる1個のソリューションにいれます.

  1. ファイル>新規作成>プロジェクト
  2. [新しいプロジェクト]ダイアログが現れる. [Win32コンソールアプリケーション Visual C++]を選択.
    1. 左パネルで, インストール済み>テンプレート>Visual C++>Win32と探していけばあるはずです.
    • 名前: p021-submit1
    • 場所: Q:\Visual Studio 2013\Projects のまま
    • ソリューション名: cs2に修正します. 2個目以降のプロジェクトでは, [ソリューションに追加](同じ)とします.
    • ソリューションのディレクトリを作成: チェック
    完了
  3. Win32アプリケーションウィザードが現れます. 超目立たない左パネル[アプリケーションの設定]をクリックし, 現れるパネルで, 追加のオプションの[空のプロジェクト]をチェックします. 完了します.
  4. ソリューションエクスプローラが表示されていない場合, メニューから表示>ソリューションエクスプローラを選びます
  5. ソリューションエクスプローラの, ソリューションcs2のp021-submit1プロジェクトの[ソースファイル]という項目を選択します. 右クリックで, 追加>新しい項目を選びます.
  6. 新しい項目の追加ダイアログで [C++ファイル(.cpp) Visual C++] を選びます.
    • 左パネルtでインストール済み>Visual C++>コードと探していけばあるはずです
  7. li>
    • 名前:submit1.c
    • 場所:いじらない
    追加
  8. 編集画面が現れるのでここでプログラムを入力します
ソリューションエクスプローラの状態

コンパイル

  1. 右パネルにsubmit1.cを表示します
  2. ビルド>submit1のビルド
注.
  • ソリューションにプロジェクトが複数ある場合, ファイルsubmit1.cを表示した状態でないと, このメニュー項目は表示されません.
  • ビルド>ソリューションのビルドを選ぶと, ソリューション内に複数のプロジェクトがある場合はすべてのプロジェクトがビルドされます.
  • 一度ビルドすると, ソースが変更されないかぎりは, 1 更新不要と出て, 再度ビルドされません(スルーされます). その場合は ビルド>submit1のリビルド.

実行

  1. ソリューションエクスプローラーの submit1 で右クリックし[スタートアッププロジェクトに設定]を選びます. p021-submit1 が太字になります.
  2. デバッグ>デバッグなしで開始

このプログラムの作成を(いったん)やめる

ファイル>submit1.cを閉じる

新しいプロジェクトを始める

ソリューションエクスプローラ内にcs2が表示されていなければ ファイル>開く>プロジェクト/ソリューションで, cs2.slnを選んで開く.

最近使ったファイルのところにcs2が現れていれば, それをクリックしてもいいです.

この後, プロジェクトを新規作成します. このとき, cs2はすでに存在するので, ソリューションは[ソリューションに追加]を選びます.

注意.
  • 「スタートアッププロジェクトに設定」しないと実行できないので注意.
  • ソリューションにプロジェクトが複数ある場合, ソリューションエクスプローラ内で, 実行したいプロジェクトが太字になっている(選択して色が反転しているだけではだめ)プロジェクトが実行されます. 太字にするためには, 右クリックから, または, プロジェクト>スタートアッププロジェクトに設定

Visual Studio いちど終了後に再開

ファイル>開く>プロジェクト/ソリューションで, cs2.slnを選んで開く.

最近使ったファイルのところにcs2が現れていれば, それをクリックしてもいいです.

このプログラムの作成を再開

ファイル>開く>プロジェクト/ソリューションで, cs2.slnを選んで開く.

注意

プログラムの実体はsubmit1.cだが, これを(例えばダブルクリックで)開いても, コンパイル, 実行は行えません. 管理情報が記録されたソリューションファイルp011.slnを開くようにします.

このサイトのコンテンツ

QRcode to hig3.net

http://hig3.net