Visual Studio 2017でのCプログラミング -- IDEの使い方(含動画)

Time-stamp: "2019-05-12 Sun 19:56 JST hig"

計算機実習室にインストールされたVisual Studio 2017 に含まれる Visual C++ 2017 をIDEでシンプルに使うときの基本的な使い方を説明します. コンソールアプリケーション(コマンドプロンプト内で実行するアプリ)を作成する方法です.

動画による説明(音声あり)

Visual Studioの起動

スタート>_04_プログラミング>Visual Studio>Visual Studio 2017を起動します. 初回起動時に行う設定

プロジェクトの作成

例として

  • 名前(プロジェクト名): p011-submit1
  • ソリューション: csb(科目の全課題共通)
  • ファイル名: submit1.c
で説明しましょう. 実際には, 課題で指定された名前を使うか, 自分の責任で決めるかしてください.

プロジェクトは, 実行ファイルを作るための複数のファイルの入れ物, ソリューションはプロジェクトを何個かまとめる入れ物, です. 計算科学☆演習では, 1個のファイル なんとか.cだけを1個のプロジェクトにいれ, すべてのプロジェクトを科目を全部まとめる1個のソリューションにいれます.

  1. (初回不要. 2回目以降)ファイル>開く>ソリューションcsb.slnを選ぶ.
  2. ファイル>新規作成>プロジェクト
  3. [新しいプロジェクト]ダイアログが現れる. [Visual C++]>[空のプロジェクト]を選択.
    • 名前: p011-submit1
    • 場所: c:\users\ユーザ名\source\repos\ のまま
    • (初回のみ)ソリューション名: csbに修正します. 最初のプロジェクト作成だけ, ソリューションのディレクトリを作成にチェックします.
    • (2回目以降)既存のソリューションに追加するにチェック
    OK
  4. ソリューションエクスプローラが表示されていない場合, メニューから表示>ソリューションエクスプローラを選びます
  5. ソリューションエクスプローラの, ソリューションcsbのp011-submit1プロジェクトの[ソースファイル]という項目を選択します. 右クリックで, 追加>新しい項目を選びます.
  6. 新しい項目の追加ダイアログで [C++ファイル(.cpp) Visual C++] を選びます.
    • 左パネルでインストール済み>Visual C++>コードと探していけばあるはずです
    • 名前:submit1.c
    • 場所:いじらない
    追加
  7. 編集画面が現れるのでここでプログラムを入力します. 注: main から return する前に, nscanf("\n");を入れておきます.
    #define _CRT_SECURE_NO_WARNINGS /* Visual C++ に必要な, scanf をエラーにしないための, #include <stdio.h> の前に書くおまじない */
    #include <stdio.h>
    	int main(){
    	printf("Hello, World\n");				
    	getchar();  /* 2文. ウィンドウを残すための おまじない */
    	getchar();  
    	return 0;
    }
    			    
ソリューションエクスプローラの状態

コンパイル

  1. 右パネルにsubmit1.cを表示します
  2. ビルド>submit1のビルド
注.
  • ソリューションにプロジェクトが複数ある場合, ファイルsubmit1.cを表示した状態でないと, このメニュー項目は表示されません.
  • ビルド>ソリューションのビルドを選ぶと, ソリューション内に複数のプロジェクトがある場合はすべてのプロジェクトがビルドされます.
  • 一度ビルドすると, ソースが変更されないかぎりは, 1 更新不要と出て, 再度ビルドされません(スルーされます). その場合は ビルド>submit1のリビルド.

実行

  1. ソリューションエクスプローラーの submit1 で右クリックし[スタートアッププロジェクトに設定]を選びます. p011-submit1 が太字になります.
  2. デバッグ>デバッグ開始

このプログラムの作成を(いったん)やめる

ファイル>submit1.cを閉じる

新しいプロジェクトを始める

ソリューションエクスプローラ内にcsbが表示されていなければ ファイル>開く>プロジェクト/ソリューションで, csb.slnを選んで開いた後でプロジェクトを新規作成して, ソリューションに追加します.

Visual Studio いちど終了後に再開

ファイル>開く>プロジェクト/ソリューションで, csb.slnを選んで開く.

最近使ったファイルのところにcsbが現れていれば, それをクリックしてもいいです.

実行するプロジェクトの選び方

  • ソリューションにプロジェクトが複数ある場合, ソリューションエクスプローラ内で, 実行したいプロジェクトが太字になっている(選択して色が反転しているだけではだめ)プロジェクトが実行されます. 太字にするためには, 右クリックから, または, プロジェクト>スタートアッププロジェクトに設定. 現在の選択にしておくと, いま開いているプロジェクトになって便利かも.

*.cの保存されている場所

課題を提出するには, *.c ファイルの保存されているパスを知る必要があります. デスクトップ>PCのパス名が表示されている部分に C:と入力し, ユーザー\(ユーザ名)\source\reposとたどると見つかります.

*.cの開き方の注意

プログラムの実体はsubmit1.cですが, これを(例えばダブルクリックで)開いても, 編集はできても, コンパイル, 実行は行えません. 管理情報が記録されたソリューションcsb.sln, プロジェクトを開くようにします.

参考書

以下の本では, 最初の30ページくらいで, 上記とほぼ同じ範囲がカバーされてます.

このサイトのコンテンツ

QRcode to hig3.net

http://hig3.net